Suchfunktion in Fertig erzeugter HTML funktionert nicht

Themen, die in kein anderes Forum passen
Daniel Richter
Beiträge: 3
Registriert: Mo Mai 11, 2020 15:37

Suchfunktion in Fertig erzeugter HTML funktionert nicht

Beitrag von Daniel Richter »

Hallo Ich bin neu hier im Forum und habe ein Problem mit der Suchfunktion in Madcap

Ich nutze die englische Version MAdcape Flare 2020
mein Projekt umfasst etwa 300 Einträge. Wenn ich die HTML Datei generiere kann ich im Dialog suchen eingeben was ich möchte es kommt nie ein Treffer.
Der Haken in den Einstellungen für die voll Text Suche ist aktiviert.
Mir ist außerdem aufgefallen das ich die partielle suche nicht aktivieren kann, mein Projekt enthält keinen Ordner der Leistung oder "Performance" heißt.

Wäre über jede Hilfe dankbar, weiss nicht mehr weiter.

Danke im Vorraus

Benutzeravatar
Jörg Ertelt
Moderator
Beiträge: 2159
Registriert: Mo Jun 20, 2005 23:41

Re: Suchfunktion in Fertig erzeugter HTML funktionert nicht

Beitrag von Jörg Ertelt »

Guten Tag Herr Richter,

Welches Ausgabeformat erzeugen Sie?
- Microsoft HTML Help (.CHM)
- HTML5
- WebHelp

Diese Information finden Sie im Project Organizer > Targets.

==
Mir ist außerdem aufgefallen das ich die partielle suche nicht aktivieren kann, mein Projekt enthält keinen Ordner der Leistung oder "Performance" heißt.
==

Es gibt solche Ordner auch nicht im Projekt.
Die partielle Suche wird im Target > Register Search aktiviert.
Viele Grüße

Jörg Ertelt, Certified Flare Instructor

MADCAP SOFTWARE
:: Lizenzen kaufen / upgraden
:: Offene und Firmenseminare

SUPPORT
:: Flare-Forum
:: Flare-Knowledgebase

HELPDESIGN • JÖRG ERTELT
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Daniel Richter
Beiträge: 3
Registriert: Mo Mai 11, 2020 15:37

Re: Suchfunktion in Fertig erzeugter HTML funktionert nicht

Beitrag von Daniel Richter »

Guten Morgen,

ich erzeuge eine Microsoft HTML Help Datei.
Der Haken bei Volltextsuche war von Anfang an gesetzt.

==
Die partielle Suche wird im Target > Register Search aktiviert.
==
Meinen Sie damit das Primary Target(STRG+F9)
Dort kann ich leider keinen Reiter mit Search finden.

Entschuldigen Sie bitte meine Unwissenheit, MadCap ist noch sehr neu für mich

Benutzeravatar
Jörg Ertelt
Moderator
Beiträge: 2159
Registriert: Mo Jun 20, 2005 23:41

Re: Suchfunktion in Fertig erzeugter HTML funktionert nicht

Beitrag von Jörg Ertelt »

==
ich erzeuge eine Microsoft HTML Help Datei.
==

Das ist die entscheidende Information.

Für das Ausgabeformat CHM ist die partielle Wortsuche nicht verfgübar. Diese ist nur für die Ausgabeformate HTML5, WebHelp und WebHelp plus verfügbar. Siehe Flare-Hilfe:
https://help.madcapsoftware.com/flare20 ... Search.htm? > Output Supported.

Zurück zu Ihrem eigentlichen Problem:

==
Wenn ich die HTML Datei generiere kann ich im Dialog suchen eingeben was ich möchte es kommt nie ein Treffer.
==

Das liegt mit hoher Wahrscheinlichkeit daran, dass die itcc.dll nicht registriert ist.

Versuchen Sie, diese .dll manuell zu registrieren.
Öffnen Sie den Pfad c:\Program Files\MadCap Software\MadCap Flare 16\Flare.app\Resources\Bin\ und doppelklicken Sie RegisterItcc.bat.
Falls die Registrierung fehlschlägt, führen Sie die RegisterItcc.bat mit Admin-Rechten aus: Auf der Datei Rechtsklick > Als Administrator ausführen.

Sollte die Registrierung dennoch fehlschlagen, lesen Sie im folgenden Beitrag, um die .dll zu registrieren:
https://kb-madcapsoftware.helpdesign.eu ... rieren.htm

Nach der Registrierung müssen Sie mit Flare die CHM neu erzeugen, damit die Suche funktioniert.

==
Entschuldigen Sie bitte meine Unwissenheit, MadCap ist noch sehr neu für mich
==

Da kann Abhilfe geschaffen werden mit unseren Flare-Seminaren:
https://www.helpdesign.eu/index.htm#cshid=900010
Viele Grüße

Jörg Ertelt, Certified Flare Instructor

MADCAP SOFTWARE
:: Lizenzen kaufen / upgraden
:: Offene und Firmenseminare

SUPPORT
:: Flare-Forum
:: Flare-Knowledgebase

HELPDESIGN • JÖRG ERTELT
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Daniel Richter
Beiträge: 3
Registriert: Mo Mai 11, 2020 15:37

Re: Suchfunktion in Fertig erzeugter HTML funktionert nicht

Beitrag von Daniel Richter »

Hallo,

Vielen Dank für die Hilfe die Suche funktioniert jetzt

Benutzeravatar
Jörg Ertelt
Moderator
Beiträge: 2159
Registriert: Mo Jun 20, 2005 23:41

Re: Suchfunktion in Fertig erzeugter HTML funktionert nicht

Beitrag von Jörg Ertelt »

Bestens!
Viele Grüße

Jörg Ertelt, Certified Flare Instructor

MADCAP SOFTWARE
:: Lizenzen kaufen / upgraden
:: Offene und Firmenseminare

SUPPORT
:: Flare-Forum
:: Flare-Knowledgebase

HELPDESIGN • JÖRG ERTELT
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Antworten